Instalación y Composer

David Portales
@davidportales

Aprenderemos a utilizar el COMPOSER para instalar paquetes PHP y a su vez se realizará el ejercicio de Instalacion de LARAVEL 5.


Para realizar comentarios debes de Iniciar Sesión ó Registrarte.


Comentarios

ach_col dijo:

Excelente introducción a Laravel 5 y Composer !! Gracias por compartir estos videos. Saludos !!

Responder

jovib_ dijo:

Excelente material David, gracias por el tiempo que le inviertes a la comunidad Laravel en latinoamerica... :)

Responder

FelipeV@lenzuel@ dijo:

Excelente gracias por los vídeos :)

Responder

Mariodener dijo:

Exelente ! Gracias por el aporte :)

Responder

tsakowi dijo:

David Excelente tutorial, gracias por compartir tus conocimientos con la comunidad. Saludos...

Responder

oscaramaiz dijo:

Gracias por el tiempo que tomas para apoyar a los que comenzamos en este framework

Responder

sadalsuud dijo:

Gracias excelentes vídeos, se nota que le gusta lo que hace :D

Responder

raumatbel dijo:

Excelente el video tutorial. Espero que vayais colgando mas vídeos para así meterme en el mundo Laravel.

Responder

josealegret dijo:

Gracias David, Excelentes los videotutoriales de laravel5, si no es pedir mucho podrias hacer un videotutorial, donde expliques como crear un servidor virtual con nginx,seria de gran ayuda

Responder

Juan Carlos dijo:

Excelente amigo! muy bien explicado

Responder

handark dijo:

Excelente explicación, muchas gracias por tomarte el tiempo de hacer estos tutoriales.

Responder

Raul dijo:

Laravel tiene algo asi como control de versiones?? donde pueda fusionar un proyecto implementado con Laravel 4.2 y ahora quiera implementar mas con Laravel 5?

Responder

David Portales dijo:

Que tal Raul , solo hay forma de darle upgrade a las versiones, desafortunadamente de la versión 4 a la 5 hay que hacerlo desde cero, ya que los cambios fueron demasiados. Asi que tienes que tener una instalacion limpia de laravel 5 y empezar a copiar controladores, modelos , vistas , etc de manera manual y con los requerimientos de la ultima version. Ahora, si estas en version 4 o 5 .. puedes instalar subversiones automaticamente con composer. Ve el video pertinente en Fundamentos de Laravel 5


barragu dijo:

Excelentes videos, espero me puedas apoyar ya que soy nuevo en laravel, Instale Apache y realize los pasos para crear un proyecto de laravel (composer create-project etc), pero al momento de hacer localhost\laravel\public\ en el navegador no pasa nada solo esta la pantalla sin ningun color como la tuya donde dice Laravel. Gracias por tus videos excelentes.

Responder

David Portales dijo:

Pueden ser varias cosas .. Una de ellas es darle el permiso 777 a la carpeta storage Otra puede ser que no hayas definido bien el VHOST y no sepa a que carpeta ir para resolver el dominio. Aun asi , mañana liberare un video en donde les enseñare a no requerir de tener un servidor corriendo de manera local


barragu dijo:

Gracias David, eso estaria bien para los que estamos iniciando. Excelentes videos


Krionoah dijo:

a mi me paso igual creo que es por los permisos, aunque ahí aun tengo problemitas para editar, pero si son los permisos 777 o 755 cualquier te sirve.


barragu dijo:

Saludos David, te comento que lo hice funcionar pero como dije soy nuevo en laravel y espero estarlo haciendo bien. Estoy trabajando con Debian Linux, Apache, MySQL y PHP todo instalado de manera independiente, la solucino que vi en una pagina es ejecutar desde consola ./artisan serve y posterioemnete logre visualizar la pagina de Laravel. Gracias y saludos.

Responder

korn-28 dijo:

Excelente vídeo, pude instalar laravel sin ningún problema, soy nuevo usando laravel y php, eso me hace pensar si tendria algun problema con el framework???, ya que soy nuevo en esta cuestion

Responder

Krionoah dijo:

mientras cumplas con los requerimientos no hay ninguna problema, aunque en la web de Laravel dice que corre con 5.6.4 yo lo estoy corriendo con 5.5 y me va esta nueva versión


supersmog dijo:

Excelente video, muy bien explicado. Muchas gracias

Responder

javier cardona dijo:

Exelente video

Responder

jhon gabriel quinteros montaño dijo:

hola gracias por los videos estan interesantes y una pregunta estoy usando debian y xampp y tengo problemas al crear un proyecto larabel cuando ejecuto el comando: composer create-project laravel/laravel --prefer-dist me sale el error: [Composer\Downloader\TransportException] The "https://packagist.org/packages.json" file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed Failed to enable crypto failed to open stream: operation failed

Responder

danielromeroauk dijo:

Jhon, active la extensión openssl en el php.ini


omarox12 dijo:

muchas gracias, tiene perfil de linkedin para recomendarlo

Responder

David Portales dijo:

Que tal Omar .. Claro : https://mx.linkedin.com/pub/jose-david-portales-sanchez/24/1a/256


Freddy del Valle Z. dijo:

Excelente muy bien detallado

Responder

Elesban dijo:

Hola, tengo unos problemas, la página se queda en blanco y manda un 500 error internal server error. ¿Alguien sabe cómo resolver eso? Gracias

Responder

Freeman Sao dijo:

Si das a conocer mas tus errores estaria mejor, asi se te podriamos ayudar.!


Borjahen dijo:

Gracias!

Responder

Krionoah dijo:

Pregunta, Si tengo versión de PHP 5.5.27, no me va el laravel 5? con el 4 me andaba de lujo pero ahora con esta nueva versión no me sale nada, después de que bajo el repo desde composer al entrar a la pagina de inicio me sale todo en blanco y no como corresponde el inicio de Laravel 5.

Responder

Mike Mancera7 dijo:

Excelente!!! gracias.

Responder

Freeman Sao dijo:

Creaste el proyecto con la sintaxis: composer create-project laravel/laravel --prefer-dist aqui donde defines el nombre del proyecto por lo que he leido se define con la siguiente sintaxis: composer create-project laravel/laravel Nombre_proyecto --prefer-dist o por qué motivo no colocaste el nombre del proyecto. saludos, aqui empezando con tus tutoriales. soy principiante en laravel. .

Responder

Freeman Sao dijo:

Empezando con el curso , estoy pensando en implementarlo en laravel 5.1, tendria algun problema en desarrollarlo en esa version, saludos soy principiante.!

Responder

yearim dijo:

Muy buen material, gracias por compartirlo. :)

Responder

richard castillo dijo:

Excelente ! llevo 7min y me gusta mucho tu explicacion aprovechar los recursos de esta web!!

Responder

Ale Diaz dijo:

Felicidades @davidportales, excelente video y muy buena explicación.

Responder